Technical Support for Jaksta Media Recorder

Support | Mac | Technical | Jaksta Media Recorder | Multiple problems recording Chaturbate streams with version 2.0.1

Multiple problems recording Chaturbate streams with version 2.0.1

Asked by Eric Lumbleau @ 07 Aug 2017 18:08 / Views: 11

 A few days ago, a much earlier version of Jaksta that I’d purchased and used for several years without experiencing problems suddenly stopped detecting streams on Chaturbate entirely. As a result, I just upgraded to version 2.0.1, but having done so, there are now two serious issues occurring that render your software almost useless and which never happened with the previous version that I had:

the first problem:  Streams that begin recording will a moment later spontaneously quit, with the status message reading: Error (std::bad_alloc). This message came up continuously, as I attempted in vain to record various streams. If you refresh the page to try and get it to start recording again, it will not detect the stream after generating this error message, no matter how many times you refresh the page.

the second problem: As chaturbate streams begin loading, about half of them will initially catch for second on an “offline” message before going on to then open the stream seconds later. With the earlier version of Jaksta that I had, simply reloading the page once or twice caused Jaksta to finally begin capturing the stream, but now, no amount of reloading will trigger Jaksta to begin recording once Jaksta fails to initially capture the stream.

Between these two issues, the majority of attempted recordings of streams on Chaturbate failed.

Both of these issues occur regardless of the browsers that I use, and I’ve tried at least 8 different browsers.

Please advise.


From Eric Lumbleau @ 07 Aug 2017 18:08

Hi Eric,

Thanks for the thorough report. It is much appreciated.

We are already aware of Chaturbate having issues and are actively trying to address them with some fixes in our next update.

My first suggestion would be to do a full reinstall of the current version and then retry the testing you have already done. 


What you will need to do is delete the app (uninstall) from Applications instead of just reinstalling over it. Then in Finder go to the top menu and then access Go > (holding one of shift/alt/control/command) Library > Application Support > Jaksta Media Recorder and delete that folder (NOTE: doing this will erase your library file list in Jaksta, but your downloaded/converted files will remain intact). This folder and its files may already be deleted when the app is removed, but it's a good idea to double check and be thorough in case it remains and is reused when the app is reinstalled. Reboot the Mac and then do a reinstall of the latest version (https://www.jaksta.com/download/mac/jaksta-media-recorder) and it will regenerate a new copy of the deleted folder and the application files. 

It would also be good if you could send through a clean log file containing the results from your testing of the current version.

To get a clean log, you will need to do the following.

- Open JMR

- Go to Preferences > General > turn Debug Mode ON (down the bottom)

- Go to Preferences > General > Find Log File

- Close JRM but keep the Finder window with the log file open

- Delete the log file and still keep the Finder window open

- Reopen JMR (this will generate a new log file)

- Run one test on a standard video stream that you know gives an error/fails 

- Close JMR once it fails or wait until it crashes

- Go back to the Finder window with the new log file and attach it here (don't copy and paste the code in it - send the file itself)

If it still fails and gives the same errors, then the next step would be to get you try testing the new beta. I have privately emailed you a link to the installer for you to try. If you would like you can try running that and see if there is any difference, then report back your findings to aid with development. 


When you install the beta, it would be good to do a full install in the same way as I outlined above, only instead of running the installer for the current version you would run the beta installer. Again, sending through another clean log file from the beta tests would be good as well, and also make sure Debug Mode is turned on during all testing.


Please let us know if there are any specific common errors or differences between the current and the beta versions that you notice. 

Regards

Liam

Jaksta Support


From Liam @ 08 Aug 2017 11:08
I've also seen severe problems with Chaturbate. They've begun using some new 'resolution' button setting in each room. When you visit the quality can be miserable until you click the resolution button and select a higher resolution. BUT, but but, as Jaksta attempts to record these streams something goes completely wrong. In some cases you don't see a normal running time within Jaksta. Sometimes it flows fine sometimes it pauses and jumps ahead a few seconds. The worst thing of all is ALL captures are now corrupted. Upon playback the capture might start off looking fine... but within seconds or minutes the playback goes completely grey or black, still retaining the sound, but the visual is useless. I wonder if Chaturbate adding that resolution setting has completely fried Jaksta? Such a shame, I used to capture with Jaksta so perfectly there. I'm still able to capture from MFC nicely, I hope they don't employ some of this horrible stuff there.

 


From Philip Lindsten @ 09 Aug 2017 06:08
Having now road-tested the new Beta version of Jaksta that an admin supplied me with after my initial message, I can now verify that most of the same issues recording streams from Chaturbate persist with this beta version. Certain streams will record (perhaps 40%). Others will either immediately end and go to a "complete" message in the status bar or fail to record as Chaturbate's stream loads and go to a "discarding" message in the status bar. As before, once a stream fails to record, no amount of refreshing your screen or using alternate browsers will cause that stream to record unless you shut down and re-start Jaksta. Even if you re-start, a stream can fail to record until you've shut down and re-started your browser multiple extra times.

I truly hope you find a way to resolve this issue soon.

 


From Eric Lumbleau @ 09 Aug 2017 08:08

Hi Eric,

Thanks for the quick turn around. I am forwarding all of your results and feedback to the development team, so it will be put to good use. 

Are you able to send through a clean log file with some testing of the beta version? Even if the failures look the same as the previous version when you are doing your testing, they might be processed differently and the readout code in the log may be different. If that is the case, then we can hopefully work out why the changes we have made are failing as a fix. Then we can come up with a solution. 

Regards

Liam

Jaksta Support


From Liam @ 09 Aug 2017 09:08

Hi again Eric,

If you find at any point that Jaksta also crashes rather than just having the download fail or not start, could you please send through an accompanying Crash Log file?

Generally when you reopen Jaksta after a crash it will give you 3 option - Report, Reopen and Ignore. If you click on Report you should be taken to another screen that gives you the option to get a Crash Log file - or at least that's what it should lead you to eventually if you follow the prompts.

Once you get the Crash Log, like the standard Log file, just attach the file itself here.

Can you please also specify which browsers you are using and which log file they are relevant to (if you end up doing isolated tests in separate browsers it would be good if we had a separate log for each).

Regards

Liam

Jaksta Support


From Liam @ 09 Aug 2017 10:08