Technical Support for Jaksta Media Recorder

Support | Windows | Technical | Jaksta Media Recorder | Monitor entries keep disappearing after updating to Jaksta Media Recorder 7.0.10.0

Monitor entries keep disappearing after updating to Jaksta Media Recorder 7.0.10.0

Asked by Jesse @ 28 Jun 2020 11:06 / Views: 38

I have noticed that after updating to the latest current version of Jaksta media recorder, all of my monitors will randomly be removed from the software. I have them all backed up and can restore them at will, however this is requiring me to be constantly aware that the items have been removed again. The prior version that was installed was 7.0.6.0 and the issue was not occurring. I have gone so far as to completely uninstall the software and remove all existing settings and reinstall and re-create the settings and monitors with the same result. Has this been happening to anyone else?


From @

If you uninstall and check to remove all your settings and library then everything will be deleted.  

Just do the upgrade option and everything will be kept.


From @

I perform that step intentionally in case something got Corrupt during the upgrade. Even after performing that step my monitors still disappear randomly.


From @

Monitors are stored in the following location

C:\Users\<your username>\AppData\Roaming\Jaksta Media Recorder 7\Monitors

Something on your computer is deleting the files if they are disappearing.


From @

yep same thing has been happening to me for months

how about we can actual get a fix for this?

saying something on your computer is deleting the files is like saying theres a ghost in your pc

how can something just be deleting the files and monitors

surely its up to you and your developers to prevent this from happening

its like taking no account or responsibility and just saying oops not our problem which is ridiculous


From @

Ive already told you there is nothing in the app that can delete your monitors.  There are however lots of things that can delete your roaming profile. 

Go find another app to use Danzer.  This app is just developed and supported by me.  If you dont like my answers then just go away. Please just go away and find something else to use.


From @

I can understand being a single point of contact for development and support, but being rude to the people asking for assistance isn't necessary.

Since your last comment telling me where the monitors were stored, I went through all of the computers that had the product installed and provided exceptions to all antivirus and anti-malware software to said folder. The monitors continued to be removed after doing this. Since this was occurring on multiple computers in the same way I dug further. I found that the monitors were in fact being deleted from the program, but only under a very specific circumstance.

If the program is using one of the monitors to download a video and fails several times in a row, this causes some sort of error state with in the program which causes the monitors to disappear. Aside from this very specific scenario, you are correct that the program does not remove the monitors on its own.


From @

And I would like to add for the record, the reason I'm using this program rather than something else is because this program was the best that I found. And if you are the person who created it, then you deserve a lot of praise for the application.


From @

Eric it wasn't directed at you.   I provide a lot of detailed support, but do reserve my right to block abusive people, delete posts etc or simply call out people who are just being constantly rude to me.   

Please refer to this thread https://www.jaksta.com/support/windows/technical/jaksta-media-recorder/why-does-it-keep-showing-queud-on-jaksta-media-recorder-6000061894  where it all started and where Denzer and I have sorted out our differences.

If you could please provide debug logs showing this behaviour I can investigate it.  Sounds like they are getting corrupted.  I have around 100 monitors constantly running and have never experienced this and looking at the analytics there are over 35k monitors running globally at any given time.  So it would be great to get to the bottom of it.  If the monitor files exist please also zip them up and attach them so I can see any corruption.

https://www.jaksta.com/support/windows/technical/jaksta-media-recorder/how-to-generate-debug-logs-6000009063 


From @

Hello there :D

Just to pop in shortly. Recently I bought Jaksta media recorder and it is BY FAR the best app for this purpose. But, recently I start to lose monitors, they just disappear... It seems to me that it started with the last Windows 10 update which I installed a few weeks ago. As well I wonder is there any limitation on the number of saved monitors? I have ATM 264... Of course, I am enabling/disabling them as needed... That number of 264 looks suspiciously close to 265 haha So I wonder is there any possible problem?

Greetings :)


From @

I had lost my email and was unable to find this thread for so long. Thank you for replying and sending me an email with the link. The issue has still been ongoing for me as well. I have just turned the logs on as was requested of me nine months ago… (Sorry it took way too long!) And I will update this post once I have been able to replicate the issue.


From @

It happened again last night, and I was able to collect the logs. I am attaching them here.


From @

Ooh it will be so nice if you guys figure it out... It happens to me every day and it really is annoying :(


From @

Thanks for your logs.

It looks like JMR was abruptly stopped at 2021-03-21 01:45:08 (not a normal shutdown) and restarted at 2021-03-21 01:47:58.  Looks like this resulted in some corrupted monitor files, although not all.  What was happening at this time?  Windows update reboot?

Could you please zip up and send me the files in C:\Users\shapm\AppData\Roaming\Jaksta Media Recorder 7\Monitors

 

 

 


From @

I'm not sure what could've happened during that time. I have scheduled reboots on that machine set at 7:30 AM, and any Windows update should be waiting for me to manually restart the machine to make sure that it comes back up and should never occur in the middle of the night.


From @

Thanks for the zip.  Yep some of the monitor files have become corrupted.

Could you have a look in your windows event log and see if you can see anything around that time.

Incase you dont know how:  https://www.howtogeek.com/123646/htg-explains-what-the-windows-event-viewer-is-and-how-you-can-use-it/

Have a look in Windows Logs > Application and System.

I will need to see how I can stop this from happening.  In the mean time please ensure you have exported the monitors so you can easily reimport them again, in the case of corruption when something like this happens.

 


From @

Looks like something did cause the machine to think it was rebooting, but since the machine is still showing uptime as being about a week, It likely didn't reboot, which means I have some work to do on my end as well. 

I really appreciate you looking into this, and please let me know if there's anything else I might be able to provide to help you out. 
image



From @

Thanks for letting me know.  I will look at moving the monitor files to sqlite which should provide better handling of system issues like this.


From @